当前位置:Linux教程 - Linux资讯 - Solaris 8.0常用命令及解释

Solaris 8.0常用命令及解释

  Debugging   truss executable   /* Trace doing of given command ( useful debugging ) */   truss -f -p <pid of a shell>   /* Using multiple windows, this can be used to trace setuid/setgid programs */   [ Back to Top ]   Arp, ethernet trouble shooting   arp -a .   /* Shows the ethernet address arp table */   arp -d myhost   /* Delete a stale ethernet entry for host myhost */     Disk Commands   du -k .   /* Reports disk space used in Kilobytes */   du -sk .   /* Reports only total disk space used in Kilobytes */   du -ad /var sort -nr   /* Tells you how big the /var files are in reverse order */   fdformat -d -U   /* Format diskette */   /usr/bin/iostat -E   /* Command to display drives statistics */   /bin/mount -F hsfs -o ro /dev/sr0 /cdrom   /* Mount an ISO 9660 CDROM */   prtvtoc /dev/rdsk/c0t0d0s2   /* Disk geometry and partitioning info */   quot -af   /* How mUCh space is used by users in kilobytes */     Driver Parameters   ndd /dev/ip \?   /* Shows IP variables in the kernel */   ndd /dev/ip ip_forwarding   /* Tells you if forwarding is on (=1) */   ndd -set /dev/ip ip_forwarding 1   /* Enables IP forwarding between interfaces */     File Manipulation   dos2unix -ascii <filename>   /* Converts DOS file formats to Unix */   split   /* Split files into pieces */   [vi] : %s/existing/new/g   /* Search and Replace text in vi */   [vi] :set nu   /* Set line numbers in vi */   [vi] :set ts=[num]   /* Set tab stops in vi */     File System   cat /dev/null > filename   /* Zero's out the file without breaking pipe */   dd if=/dev/rdsk/... of=/dev/rdsk/... bs=4096   /* Make a mirror image of your boot disk */   df -k grep dg awk '{print $6}' xargs -n 1 umount   /* Unmount all file systems in disk group dg */   fsck -F ufs /dev/rdsk/c0t0d0s0   /* Check a UFS filesystem on c0t0d0s0 */   fsck -F ufs -y /dev/rdsk/c0t0d0s0   /* Check answering yes to all questions */   fsck -F ufs -o b=97472 /dev/rdsk/c0t0d0s0   /* Check using an alternate super block */   gzip -dc file1.tar.gz tar xf -   /* Unpack .tar.gz files in place */   ls -la awk '{ print $5," ",$9 }' sort -rn   /* File sizes of current Directory */   mount -f pcfs /dev/dsk/c0d0p1 /eXPort/dos   /* Mount DOS fdisk partition from Solaris */   mount -F ufs -o rw,remount /   /* Used to remount root to make it writeable */   mount -o remount,logging /spare   /* Re-mount the ro file system rw and turn on ufs logging */   tar cvf filename.tar   /* Create a tape (tar) archive */   tar xvf filename.tar   /* Extract a tape (tar) archive */   tar cf - . (cd /newdir ;
[1] [2] [3] 下一页 

tar xf -)   /* Recursively copy files and their permissions */   /sbin/uadmin x x   /* Syncs File Systems and Reboots systems fast */   zcat <patch_file.tar.Z tar xvf -   /* Extract the patch_file that is a compressed tar file */     File Transfer   put " tar cf - ." filename.tar   /* Undocumented Feature of FTP */   find . -depth cpio -pdmv /path/tobe/copied/to   /* Fast alternative to cp -pr */   sendport   /* Transferring large numbers of files within the same ftp control session */     General   /usr/bin/catman -w   /* Create windex databases for man page directories */   mailx -H -u <username>   /* List out mail headers for specified user */   set filec   /* Set file-completion for csh */     Hardware   cfgadm   /* Verify reconfigurable hardware resources */   m64config -prconf   /* Print M64 hardware configuration */   m64config -depth 824   /* Sets the screen depth of your M64 graphics accelerator */   m64config -res 'video_mode'   /* Change the resolution of your M64 graphics accelerator */     Kernel   /usr/sbin/modinfo   /* Display kernel module information */   /usr/sbin/modload <module>   /* Load a kernel module */   /usr/sbin/modunload -i <module id>   /* Unload a kernel module */   nm -x /dev/ksyms grep OBJ more   /* Tuneable kernel parameters */   /usr/sbin/sysdef   /* Show system kernal tunable details */     Memory   prtconf grep "Memory size"   /* Display Memory Size */     Network Information   ndd /dev/arp arp_cache_report   /* Prints ARP table in cache with IP and MAC address */   netstat -a grep EST wc -l   /* Displays number active established connections to the localhost */   netstat -k hme0   /* Undocumented netstat command */   netstat -i   /* Show the TCP/IP network interfaces */   netstat -np   /* Similar to arp -a without name resolution */   netstat -r   /* Show network route table */   netstat -rn   /* Displays routing information but bypasses hostname lookup. */   netstat -a more   /* Show the state of all sockets */   traceroute <ipaddress>   /* Follow the route to the ipaddress */     Network/Tuning   ifconfig eth0 mtu 1500   /* Change MTU of interface */   ifconfig eth0 10.1.1.1 netmask 255.255.255.255   /* Add an Interface */   /sbin/ifconfig hme0:1 inet 10.210.xx.xxx netmask 255.255.0.0 broadcast 10.210.xxx.xxx   /* Virtual Interfaces */   /sbin/ifconfig hme0:1 up   /* Bring virtual interface up */   /usr/sbin/ndd -set /dev/hme adv_100fdx_cap 1   /* Nailling to 100Mbps */   ndd -set /dev/ip ip_addrs_per_if 1-8192   /* To set more than 256 virtual ip addresses. */   ndd -set /dev/tcp tcp_xmit_hiwat 65535   /* Increase TCP-transmitbuffers */   ndd -set /dev/tcp tcp_recv_hiwat 65535   /* Increase TCP-receivebuffers */     Processes   fuser -uc /var   /* Processes that are running from /var */   kill -HUP `ps -ef grep [p]roccess awk '{print $2}'`   /* HUP any related process in one step */   pfiles <
上一页 [1] [2] [3] 下一页 

pid>   /* Shows processes' current open files */   pkill -n <name>   /* Kill a process by name */   kill `ps -ef grep program_name grep -v grep cut -f8 -d ' '`   /* pkill for solaris 2.6 */   prstat -a   /* An alternative for top command */   /usr/ucb/ps -aux more   /* Displays CPU % usage for each process in ascending order */   /usr/ucb/ps -auxww grep <process name>   /* Gives the full listing of the process (long listing) */   ps -ef grep -i <string> awk '{ print $2 }'   /* Creates list of running PID by */   ps -ef grep -v "0:00" more   /* Gives you a list of any process with CPU time more than 0:00 */   ps -ef more   /* Show all processes running */   ps -fu Oraclegrep pmon   /* See which instances of Oracle are running */   /usr/proc/bin/ptree <pid>   /* Print the parent/child process 'tree' of a process */   /usr/proc/bin/pwdx <pid>   /* Print the working directory of a process */   top -b 1   /* Returns the process utilizing the most cpu and quits */     Resource Management   /usr/bin/ldd [filename]   /* List the dynamic dependencies of executable files */   /usr/proc/bin/pmap pid   /* Report address space map a process occupies */     Route Configuration   route add net 128.50.0.0 128.50.1.6 1   /* Adds rou

(出处:http://www.sheup.com)


上一页 [1] [2] [3] 

right">(出处:http://www.sheup.com)


上一页 [1] [2] [3] [4]